Payment Manager unavailable

Minor incident Dashboard
2023-06-05 11:39 CET · 3 hours, 16 minutes

Updates

Update

All transactions are available in the Payment Manager

June 5, 2023 · 14:24 CET
Resolved

Payment manager service disruptions are now over. We are actively monitoring the platform.
Daily / hourly KPis will be back in few minutes.

June 5, 2023 · 14:11 CET
Update

We identified the root cause of the issue and are applying changes to stabilize the platform

June 5, 2023 · 12:37 CET
Investigating

We have detected issues and we are currently investigating, we’ll update you soon.

June 5, 2023 · 11:47 CET

← Back